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Security information
IDEC SmartRelay provides products and solutions with industrial security functions that support the secure 
operation of plants, systems, machines and networks.

In order to protect plants, systems, machines and networks against cyber threats, it is necessary to implement 
– and continuously maintain – a holistic, state-of-the-art industrial security concept.

Customers are responsible for preventing unauthorized access to their plants, systems, machines and networks. 
Such systems, machines and components should only be connected to an enterprise network or the internet if 
and to the extent such a connection is necessary and only when appropriate security measures (e.g. firewalls 
and/or network segmentation) are in place.

IDEC SmartRelay's products and solutions undergo continuous development to make them more secure. IDEC 
strongly recommends that product updates are applied as soon as they are available and that the latest product 
versions are used. Use of product versions that are no longer supported, and failure to apply the latest updates 
may increase customers' exposure to cyber threats.

Data protection
This product does not process / save any personal information, but only technical functional data (e.g. time 
stamps). If the user links this data to other data (e.g. shift plans) or if the user save personal information on the 
same medium (e.g. hard disk) and therefore creates a personal reference in the process, the user has to ensure 
meeting the guidelines regarding data protection in their region of use.

Note
Notes on protecting administrator accounts
A user with administrator rights has extensive access and manipulation options available to the 
system.
Therefore, ensure there are adequate safeguards for protecting the administrator accounts to 
prevent unauthorized changes. To do this, use secure passwords and a standard user account for 
normal operation. Other measures, such as the use of security policies, should be applied as 
needed.

Note
To protect WindLGC and FL1F Web Editor from any undesired manipulation when your PC suffers 
malicious attacks from the Internet, we recommend that you install whitelist-based security software 
on the PC. Then use the whitelist-based security software to manage the software installed on your 
PC.
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General introduction
FL1F Access Tool is an add-in for Excel. It connects to IDEC SmartRelay Base Module through HTTP or HTTPS.

FL1F Access Tool provides the following features:

• Set data synchronization period
• Show history data
• Start or stop the data synchronization
• Get value of IDEC SmartRelay Variables such as I, Q and M
• Record all variables values and save them in log files

Compatibility
• If FL1F Access Tool connects to IDEC SmartRelay Base Module through HTTP, the compatibility information 

is as follows:

Supported Office Excel versions

– Office Excel 2007
– Office Excel 2010
– Office Excel 2013
– Office Excel 2016
– Office Excel 2019
– Office Excel 365

Supported IDEC SmartRelay Base Modules

– FL1F
– FL1F FS5
– FL1F FS6 and later versions

Supported Windows operating systems

– Windows 7
– Windows 8
– Windows 10
– Windows 11

• If FL1F Access Tool connects to IDEC SmartRelay Base Module through HTTPS, the compatibility 
information is as follows:

Supported Office Excel versions

– Office Excel 2007
– Office Excel 2010
– Office Excel 2013
– Office Excel 2016
– Office Excel 2019
– Office Excel 365

Supported IDEC SmartRelay Base Modules

– FL1F FS6 and later versions

Supported Windows operating systems

– Windows 8
– Windows 10
– Windows 11
FL1F Access Tool Help
ii



Comparison between BM Version Number and Hardware Type in WindLGC

Document History
The following editions of FL1F Access Tool have been published:

BM Version Number WindLGC
FL1F FS4 or earlier version FL1F
FL1F FS5 FL1F FS5
FL1F FS6 FL1F FS6

Note
BM version number is written on the base module.
Refer to the user’s manual for details.

Release date Version Edition
02/2019 V2.0.0 First edition
11/2024 V2.1.1 Second edition
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1Operating the FL1F Access Tool

1.1 Prerequisite

Before using FL1F Access Tool, make sure that you meet the following requirements:

• Install FL1F Access Tool in Microsoft Excel.

• Connect your PC to the target IDEC SmartRelay Base Module.

• Enable the Web server access through WindLGC. On how to enable the Web server 
access, refer to WindLGC Online Help.

1.2 Install FL1F Access Tool
Before starting working with FL1F Access Tool, you need to install it first.

1. Copy FL1FAccessTool.xlam to your computer.

2. Start Excel.

3. On the File menu, point to Options, and then click Add-Ins.

Note
You can only use FL1F Access Tool in Local Network with a firewall.
 In current version, FL1F Access Tool only supports one Base Module connection.

Note
If you enable the HTTPS access, you need to import SmartRelay root certificate in 
Windows before you use FL1F Access Tool. On how to import SmartRelay root 
certificate, refer to the chapter Security -> Installing SmartRelay Root certificate of 
IDEC SmartRelay User's Manual.
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Operating the FL1F Access Tool
1.2 Install FL1F Access Tool
4. In the Manage box, select Excel Add-ins, and then click Go… button.

5. In the "Add-Ins available" pane, click Browse… button.
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Operating the FL1F Access Tool
1.2 Install FL1F Access Tool
6. Browse to the folder which you save "FL1F Access Tool" in step one and select the tool.

Result: FL1F Access Tool is listed in the "Add-Ins available" pane and its check box is 
automatically selected.

7. Click OK.
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Operating the FL1F Access Tool
1.3 FL1F Access Tool Menu
1.3 FL1F Access Tool Menu
After installing FL1F Access Tool successfully, click the toolbar Add-Ins, and then FL1F 
Access Tool menu is displayed as follows.

FL1F Access Tool menu consists of two options:

• Start/Stop: you can use it to start or stop data synchronization.

• FL1F Access Tool: click it and a drop-down menu appears. This drop-down menu includes 
Log In Panel, Configure Panel and About Panel.
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Operating the FL1F Access Tool
1.3 FL1F Access Tool Menu
1.3.1 Log In Panel

Procedure
After installing FL1F Access Tool, log in according to the following steps:

1. Click Log In in the drop-down list of FL1F Access Tool menu

2. Enter IP address and password of your IDEC SmartRelay Base Module after a Login 
panel appears, and then check the box Run when log in.

3. Click the Log In button.

Note
FL1F Access Tool shares the same access control with Web server.
FL1F Access Tool Help
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Operating the FL1F Access Tool
1.3 FL1F Access Tool Menu
Login failure troubleshooting
If the login goes wrong, a dialog appears to remind you that your login fails. You can refer to 
the following table to troubleshoot the error cause and fix the error through corresponding 
solution. 

Error code Possible remedy
2146232576 
(80131700)

Install .NET Framework 3.5 on your PC:
Open Control Panel in your PC → Click Program and Features → Click Turn 
Windows features on or off → Check the box of .NET Framework 3.5. 

No error code Restart your PC.
Enable macros in the Excel:
Click File in Excel → Click Options → Click Trust Center → Click Trust Center 
Settings → Click Macro Settings → Select Enable all macros → save settings and 
restart Excel.
If you fail to login the IDEC SmartRelay Base Module in HTTPS mode, you need to 
install the latest SmartRelay Root certificate on your PC. About how to install the 
certificate, refer to section "Security -> Installing SmartRelay Root certificate" in 
IDEC SmartRelay User's Manual.
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Operating the FL1F Access Tool
1.3 FL1F Access Tool Menu
1.3.2 Configure Panel
In the configure panel, you can set data synchronization period and history data number 
according to the following steps:

1. In the drop-down list of FL1F Access Tool menu, click Configure, and then the configure 
panel is displayed.

2. In the scroll bar of Synchronization Period, you can select one number depending on your 
need.

3. In the scroll bar of History Data Number, you can drag the scroll box from up to down to 
select one number for the history data.

Note
The synchronization period can be configured as the following numbers: 1,10, 30, 60 
seconds, and the default is 1 second.

Note
The history data number varies from 1 to 100, and the default is 5.
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Operating the FL1F Access Tool
1.3 FL1F Access Tool Menu
4. After selecting the number for synchronization period and history data number, click button 
OK.
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Operating the FL1F Access Tool
1.3 FL1F Access Tool Menu
1.3.3 About Panel
About panel shows the version information of FL1F Access Tool.
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Operating the FL1F Access Tool
1.4 Get IDEC SmartRelay Variable Value
1.4 Get IDEC SmartRelay Variable Value

After logging in (Page 5) FL1F Access Tool successfully, you can get IDEC SmartRelay 
Variable values by inputting "=FL1VAR("id")" in a cell. Then the real time value of this specific 
variable is displayed in the cell. The variable value updates according to the data 
synchronization period you set in the Configure Panel (Page 7). 

"id" means the identification for IDEC SmartRelay variables. It consists of variable type and 
valid index. For one dimensional variables, there is only one index, for example: Q1, AI1, 
VW0. IDEC SmartRelay also supports multiple dimensional variables which have multiple 
index, for example: SR1.1.

Note
Make sure that you enable Web server access of the target IDEC SmartRelay Base 
Module before using the FL1F Access Tool.

Note
When you input an invalid or unsupported id for IDEC SmartRelay, FL1F Access Tool 
cannot return data. The following table shows the variables that can be got with FL1F 
Access Tool.
FL1F Access Tool Help
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Operating the FL1F Access Tool
1.4 Get IDEC SmartRelay Variable Value
 

Variable Variable
Type

Valid Index Remarks Example Example
Min Max

BM working status STATUS N/A N/A Offline
Connecting
Stop
Running
Recovering
Invalid Status

=FL1VAR("STATUS")

Show the Time TIME N/A N/A The time format is YYYY- 
MM-DD hh:mm:ss

=FL1VAR("TIME")

Flag M 1 64 =FL1VAR("M1")
Analog memory 
markers

AM 1 64 =FL1VAR("AM1")

Digital Outputs Q 1 20 =FL1VAR("Q1")
Analog outputs AQ 1 8 =FL1VAR("AQ1")
Digital Inputs I 1 24 =FL1VAR("I1")
Cursor keys Cur 1 4 =FL1VAR("CUR1")
TDE Function keys F 1 4 =FL1VAR("F1")
Shift register bits SR 1 4 The first dimension ad-

dresses index of SR
=FL1VAR("SR1.1")

1 8 The second dimension 
addresses index of SR

=FL1VAR("SR4.8")

Network inputs NI 1 64 =FL1VAR("NI1")
Analog Inputs AI 1 8 =FL1VAR("AI1")
Network analog 
inputs

NAI 1 32  =FL1VAR("NAI1")

Network outputs NQ 1 64 =FL1VAR("NQ1")
Network analog 
outputs

NAQ 1 16 =FL1VAR("NAQ1")

Variable Memory 
(In Bit)
(FL1F FS5 and the 
later version)

VB 0 850 The first dimension ad-
dresses index of VB

=FL1VAR("VB0.0")
VXB 0 2047 =FL1VAR("VXB0.0")
VRB 0 511 =FL1VAR("VRB0.0")
VB, VXB, 
VRB

0 7 The second dimension 
address index of VB

=FL1VAR("VB89.7")

Variable Memory 
(In Byte)

VB 0 850 =FL1VAR("VB0")
VXB 0 2047 =FL1VAR("VXB5")
VRB 0 511 =FL1VAR("VRB6")

Variable Memory 
(In Words)

VW 0 849 The index is counted by 
Byte. It will try to reinter-
pret the byte and its next 
byte as a big-endian word.

=FL1VAR("VW0")
VXW 0 2046 =FL1VAR("VXW6")
VRW 0 510 =FL1VAR("VRW8")

Variable Memory 
(In Double Words)

VD 0 847 The index is counted by 
Byte. It will try to reinter-
pret the byte and its next 3 
bytes as a big -endian 
double word.

=FL1VAR("VD0")

VXD 0 2044 =FL1VAR("VXD8")

VRD 0 508 =FL1VAR("VRD12")
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Operating the FL1F Access Tool
1.4 Get IDEC SmartRelay Variable Value
FL1VAR combinations
You can use the following combinations to set the data format by adding them after the 
function FL1VAR. For example, input "=FL1VARS("AI")" in a cell, you can get signed value for 
AI.

You can use combination L together with S, H or B. For example, when you input 
"=FL1VARSL("AI1")", you can get a log file with signed value of AI1.

Whether you input L before or after S/H/B, you get the same output for 
"=FL1VARSL("AI1")" and "=FL1VARLS("AI1")".

Trend direction (TR/TD)

You can add the argument of trend direction after FL1VAR combination and this argument is 
optional. "TR" means that history data is shown on the right of the cell where the formula 
"=FL1VAR("id")" is placed. "TD" means the history data is shown on the downside of the cell 
where the formula is placed. For example, FL1VARS( "id", "TR") means the signed value and 
history data is shown on the right of the cell.

Generate log files with FL1VARL
To generate log files for a variable, input "=FL1VARL("id")" in a cell. The log file updates 
according to the data synchronization period you set in the Configure Panel (Page 7).

• Log files are saved as csv files. The file name is composed of three parts: the excel file 
name, IP of the connected BM, and the time stamp. For example,
Test_192.168.0.1_20160406080001.

• Log files are saved in the parent folder of the working excel. If you haven't save the excel 
yet or the parent folder cannot be saved, the log files are saved in the My document folder 
of the Windows active user.

Format letter Description Data Log letter Description
S Show signed value L Write the value to data log
U Show unsigned value
B Show binary value
H Show hexadecimal value

The default is unsigned value The default is that the value is not 
writ-ten in data log
FL1F Access Tool Help
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Operating the FL1F Access Tool
1.4 Get IDEC SmartRelay Variable Value
• If you use FL1VARL for multiple variables, their log files are saved in different columns of 
one csv file. See an example of log file as follows:

• You can add a suffix (@ serial number) to sort your variables in the log files. For example, 
if you have five variables in your working excel, you input them as 
FL1VARL("Flag1@1"), FL1VARL("I1@2"), FL1VARL("Q1@3"),
FL1VARL("SR2.5@4"), FL1VARL("F5@5"). Then the variables are listed in your log files 
as Flag1, I1, Q1, SR2.5, F5. The default serial number is 0.

Note
Capacity of FL1F Access Tool
A csv file has a maximum of 20000 lines. FL1F Access Tool will automatically write to a 
new log file when a log file is full.
You can have up to 500 log files in a folder. When the limitation is reached, your old log 
files will be removed in chronological order.
FL1F can only synchronize 72 variables for all supported types.
FL1F FS5 and later version can synchronize 75 consecutive VM or 7 discrete VM. 
FL1F FS5 and later version has no limit for the other variables.
The variables which cannot be synchronized are returned as invalid data.
FL1F Access Tool Help
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Operating the FL1F Access Tool
1.5 Uninstall the FL1F Access Tool
1.5 Uninstall the FL1F Access Tool
Follow the below steps to remove FL1F Access Tool completely from your computer.

1. Start Excel.

2. On the File menu, point to Options, and then click Add-Ins.

3. In the Manage box, select Excel Add-ins, and then click Go... button.
FL1F Access Tool Help
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Operating the FL1F Access Tool
1.5 Uninstall the FL1F Access Tool
4. In the "Add-Ins available" pane, uncheck the check box next to "FL1FAccesstool".

5. Click OK.

6. On the toolbar Add-Ins, right-click FL1F Access Tool.

7. Select Delete Custom Command.

8. Delete the source file FL1F Access Tool from your computer.
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Operating the FL1F Access Tool
1.6 Reinstall the FL1F Access Tool
1.6 Reinstall the FL1F Access Tool
FL1F Access Tool cannot work properly in the following cases.

• You move FL1F Access Tool to another location.

• You update excel to a higher version.

• You use excel workbook in another computer.

For the existing workbooks can work properly, follow the below steps to update the tool.

1. Reinstall FL1F Access Tool. On how to reload your FL1F Access Tool, refer to Install 
FL1F Access Tool (Page 1).

2. Edit the links in your workbook.

Edit the links in your workbook
Update the link to your FL1F Access Tool according to the following instructions:

1. On the Data tab, in the Connections group, click Edit Links.

2. Check the status in the Status column.

3. Click Change source... and browse to the folder where FL1F Access Tool is stored.
FL1F Access Tool Help
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Operating the FL1F Access Tool
1.6 Reinstall the FL1F Access Tool
4. Click the FL1F Access Tool to update the links. The status of the source changes to "OK".

5. Click Close.
FL1F Access Tool Help
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